Ваш браузер устарел. Рекомендуем обновить его до последней версии.

Полезное

Ссылки

Яндекс.Метрика

ОГЭ информатика. Вопрос № 20

Опубликовано 19.09.2016

Умение написать короткий алгоритм в среде формального исполнителя (вариант задания 20.1) или на языке программирования (вариант задания 20.2)

Для решения задания 20.1 потребуется система программирования Кумир. Можно взять отсюда  Версия 2.1.0 у меня на виндовс 8 не пошла. "КуМир" версия 1.9.0 работает нормально.

 

Задания с "Роботом"

Исполнитель Робот умеет перемещаться по лабиринту, начерченному на плоскости, разбитой на
клетки. Между соседними (по сторонам) клетками может стоять стена, через которую Робот пройти не
может.
У Робота есть девять команд. Четыре команды это команды­ приказы:
вверх вниз влево вправо
При выполнении любой из этих команд Робот перемещается на одну клетку соответственно: вверх ↑,
вниз ↓, влево ←, вправо →. Если Робот получит команду передвижения сквозь стену, то он
разрушится.
Также у Робота есть команда закрасить, при которой закрашивается клетка, в которой Робот
находится в настоящий момент.
Ещё четыре команды это команды проверки условий. Эти команды проверяют, свободен ли путь
для Робота в каждом из четырёх возможных направлений:
сверху свободно снизу свободно слева свободно справа свободно
Эти команды можно использовать вместе с условием «eсли», имеющим следующий вид:
если
условие то
последовательность команд
все
Здесь
условие одна из команд проверки условия.
Последовательность команд это одна или несколько любых команд­приказов.
Например, для передвижения на одну клетку вправо, если справа нет стенки и закрашивания клетки,
можно использовать такой алгоритм:
если справа свободно то
вправо
закрасить
все
В одном условии можно использовать несколько команд проверки условий, применяя логические
связки и, или, не, например:
если (справа свободно) и (не снизу свободно) то
вправо
все
Для повторения последовательности команд можно использовать цикл «пока», имеющий следующий
вид:
нц пока
условие
последовательность команд
кц
Например, для движения вправо, пока это возможно, можно использовать следующий алгоритм:
нц пока справа свободно
вправо
кц

 

Задание 1  

 

Задание 2

 

 

Задание 3

 

 

Задание 4

 

 

Задание 5

 

 

Задание 6

 

 

Задание 7

 

 

Задание 8

 
   

       

 

 

 

 

 

 

 

 

 

 

 

 

Топка сайта

География

 ОГЭ 2016. География 30 вопрос

Горные породы Профиль

Тесты для ОГЭ. Обществознание.

ИР9 Проверочный тест по теме "Великая Отечественная война

 Основное содержание программы 8 класс.

 ОГЭ 2016. География 14 вопрос

 Биология 9 класс. Проверочный тест по теме "Строение клетки"

Тест-практикум по географии 6 класс "Координаты"